Deno を CentOS 7 にインストールする方法 GLIBC_2.18対応

CentosにDenoをインストール

今回はDenoをCentos7にインストールする方法を書き溜めます。

広告

CentOSにインストール

そもそもDenoはCentos7を対象としておらずCentOS8を推奨しています。

DenoをCentos7にインストールするのは、
一行スクリプトを入力するだけだが、依存パッケージのインストールが必要になるのでそれも含める。

unzipだけでなくCentos7ではインストールされていないGLIBC_2.18を入れる必要がある。
GLIBC_2.18じゃないと下記のようなエラーがでる。

エラーからわかるようにDenoはCentos7をサポートしておらず、Centos8じゃないといけない。。。
そのためglibc 2.18 はyumでは入れられないからコンパイルします。
下記をコピペすればOK。

denoインストールなんてよゆうだぜ!!
GLIBC2.18には注意だぞ!

完了したらversionで確認。

詳しくは公式サイトで確認してね。



じゃあね〜〜〜〜。